using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*?<body>)(?:\s*)((.*\s)*)<\/body>";
string input = @" <html>
<head>
</head>
<body>
-- Maximum Health:<br>--<br>--<br>-- Current Health:<br>--<br>--<br>--
Base Damage:<br>--<br>--<br>-- Speed:<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}