import re
regex = re.compile(r"(?:\s*?<body>)(?:\s*)((.*\s)*)<\/body>", flags=re.MULTILINE)
test_str = (" <html>\n"
" <head>\n\n"
" </head>\n"
" <body>\n"
" -- Maximum Health:<br>--<br>--<br>-- Current Health:<br>--<br>--<br>--\n"
" Base Damage:<br>--<br>--<br>-- Speed:<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")