$re = '/(?:\s*?<body>)(?:\s*)((.*\s)*)<\/body>/m';
$str = ' <html>
<head>
</head>
<body>
-- Maximum Health:<br>--<br>--<br>-- Current Health:<br>--<br>--<br>--
Base Damage:<br>--<br>--<br>-- Speed:<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);