const regex = /(?:\s*?<body>)(?:\s*)((.*\s)*)<\/body>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*?<body>)(?:\\s*)((.*\\s)*)<\\\/body>', 'gm')
const str = ` <html>
<head>
</head>
<body>
-- Maximum Health:<br>--<br>--<br>-- Current Health:<br>--<br>--<br>--
Base Damage:<br>--<br>--<br>-- Speed:<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}