package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s*?<body>)(?:\s*)((.*\s)*)<\/body>`)
var str = ` <html>
<head>
</head>
<body>
-- Maximum Health:<br>--<br>--<br>-- Current Health:<br>--<br>--<br>--
Base Damage:<br>--<br>--<br>-- Speed:<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>--<br>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}