#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w.+-]+@[a-zA-z0-9.-]+\.\w{2,6}"
Local $sString = "ewfda fdffdsfddsa fdsaf ewewem thurn@live.com rewqreqw" & @CRLF & _
"fda fdefhgfjh fdsa fdsaf fangorn@hotmail.com rewqr re q rewqrrwq" & @CRLF & _
"fda fdfdf dsa fdsaf euice@outlook.com ewrewqre" & @CRLF & _
"fd" & @CRLF & _
"" & @CRLF & _
"a f fhjhfdffdsaf fdsa fdsaf rgarcia@optonline.net rewqrewq" & @CRLF & _
"fda fdfdsa fdsaf mxiao@yahoo.com rewreqw rewqer " & @CRLF & _
"fda fd hffdsa fdsaf firstpr@att.net r ewqrewq"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")