using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w.+-]+@[a-zA-z0-9.-]+\.\w{2,6}";
string input = @"ewfda fdffdsfddsa fdsaf ewewem thurn@live.com rewqreqw
fda fdefhgfjh fdsa fdsaf fangorn@hotmail.com rewqr re q rewqrrwq
fda fdfdf dsa fdsaf euice@outlook.com ewrewqre
fd
a f fhjhfdffdsaf fdsa fdsaf rgarcia@optonline.net rewqrewq
fda fdfdsa fdsaf mxiao@yahoo.com rewreqw rewqer
fda fd hffdsa fdsaf firstpr@att.net r ewqrewq";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}