package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w.+-]+@[a-zA-z0-9.-]+\.\w{2,6}`)
var str = `ewfda fdffdsfddsa fdsaf ewewem thurn@live.com rewqreqw
fda fdefhgfjh fdsa fdsaf fangorn@hotmail.com rewqr re q rewqrrwq
fda fdfdf dsa fdsaf euice@outlook.com ewrewqre
fd
a f fhjhfdffdsaf fdsa fdsaf rgarcia@optonline.net rewqrewq
fda fdfdsa fdsaf mxiao@yahoo.com rewreqw rewqer
fda fd hffdsa fdsaf firstpr@att.net r ewqrewq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}