import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w.+-]+@[a-zA-z0-9.-]+\\.\\w{2,6}";
final String string = "ewfda fdffdsfddsa fdsaf ewewem thurn@live.com rewqreqw\n"
+ "fda fdefhgfjh fdsa fdsaf fangorn@hotmail.com rewqr re q rewqrrwq\n"
+ "fda fdfdf dsa fdsaf euice@outlook.com ewrewqre\n"
+ "fd\n\n"
+ "a f fhjhfdffdsaf fdsa fdsaf rgarcia@optonline.net rewqrewq\n"
+ "fda fdfdsa fdsaf mxiao@yahoo.com rewreqw rewqer \n"
+ "fda fd hffdsa fdsaf firstpr@att.net r ewqrewq";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}