# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w.+-]+@[a-zA-z0-9.-]+\.\w{2,6}"
test_str = ("ewfda fdffdsfddsa fdsaf ewewem thurn@live.com rewqreqw\n"
"fda fdefhgfjh fdsa fdsaf fangorn@hotmail.com rewqr re q rewqrrwq\n"
"fda fdfdf dsa fdsaf euice@outlook.com ewrewqre\n"
"fd\n\n"
"a f fhjhfdffdsaf fdsa fdsaf rgarcia@optonline.net rewqrewq\n"
"fda fdfdsa fdsaf mxiao@yahoo.com rewreqw rewqer \n"
"fda fd hffdsa fdsaf firstpr@att.net r ewqrewq")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.