using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^,]+)\s?,\s?(Round[^\d]+)\s(\d+\sday)\s?-\s?(.+)$";
string input = @"Some random string , Round A 1 day - Trip
Olololo, Round B 2 day - Haha";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}