package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([^,]+)\s?,\s?(Round[^\d]+)\s(\d+\sday)\s?-\s?(.+)$`)
var str = `Some random string , Round A 1 day - Trip
Olololo, Round B 2 day - Haha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}