$re = '/^([^,]+)\s?,\s?(Round[^\d]+)\s(\d+\sday)\s?-\s?(.+)$/im';
$str = 'Some random string , Round A 1 day - Trip
Olololo, Round B 2 day - Haha';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);