re = /^([^,]+)\s?,\s?(Round[^\d]+)\s(\d+\sday)\s?-\s?(.+)$/im
str = 'Some random string , Round A 1 day - Trip
Olololo, Round B 2 day - Haha'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end