import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]+)\\s?,\\s?(Round[^\\d]+)\\s(\\d+\\sday)\\s?-\\s?(.+)$";
final String string = "Some random string , Round A 1 day - Trip\n"
+ "Olololo, Round B 2 day - Haha";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}