using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-ZÄäÖöÜüß.\s-]+?)\s*(\d+(?:[/-]\d+)?(?:[A-Z](?:-[A-Z])?)?)\b";
string input = @"Berliner Str. 74
Hindenburgdamm 27, Hygiene-Institut
Peschkestr. 5a/Holsteinische Str. 44
Lankwitzer Str. 13-17a
Fidicinstr. 15A
Johanna-Stegen-Strasse 14a-d
Friedrichshaller Str. 7
Haudegen Weg 15/17
Südwestkorso 9";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}