import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-ZÄäÖöÜüß.\\s-]+?)\\s*(\\d+(?:[/-]\\d+)?(?:[A-Z](?:-[A-Z])?)?)\\b";
final String string = "Berliner Str. 74\n"
+ "Hindenburgdamm 27, Hygiene-Institut\n"
+ "Peschkestr. 5a/Holsteinische Str. 44\n"
+ "Lankwitzer Str. 13-17a\n"
+ "Fidicinstr. 15A\n"
+ "Johanna-Stegen-Strasse 14a-d\n"
+ "Friedrichshaller Str. 7\n"
+ "Haudegen Weg 15/17\n"
+ "Südwestkorso 9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}