re = /^([A-ZÄäÖöÜüß.\s-]+?)\s*(\d+(?:[\/-]\d+)?(?:[A-Z](?:-[A-Z])?)?)\b/mi
str = 'Berliner Str. 74
Hindenburgdamm 27, Hygiene-Institut
Peschkestr. 5a/Holsteinische Str. 44
Lankwitzer Str. 13-17a
Fidicinstr. 15A
Johanna-Stegen-Strasse 14a-d
Friedrichshaller Str. 7
Haudegen Weg 15/17
Südwestkorso 9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end