import re
regex = re.compile(r"^([A-ZÄäÖöÜüß.\s-]+?)\s*(\d+(?:[/-]\d+)?(?:[A-Z](?:-[A-Z])?)?)\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Berliner Str. 74\n"
"Hindenburgdamm 27, Hygiene-Institut\n"
"Peschkestr. 5a/Holsteinische Str. 44\n"
"Lankwitzer Str. 13-17a\n"
"Fidicinstr. 15A\n"
"Johanna-Stegen-Strasse 14a-d\n"
"Friedrichshaller Str. 7\n"
"Haudegen Weg 15/17\n"
"Südwestkorso 9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")