$re = '/^(-?\d+)([a-z]*)|(-)?([a-z]+)$/mi';
$str = '-24mn
-100BC
100BC
100
BC
-bC
-100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);