re = /^(-?\d+)([a-z]*)|(-)?([a-z]+)$/mi
str = '-24mn
-100BC
100BC
100
BC
-bC
-100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end