// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(-?\d+)([a-z]*)|(-)?([a-z]+)$").unwrap();
let string = "-24mn
-100BC
100BC
100
BC
-bC
-100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}