#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)244[9][19]\d{7}"
Local $sString = "244929164344" & @CRLF & _
"244915392194" & @CRLF & _
"244943757798" & @CRLF & _
"244922955344" & @CRLF & _
"244914094882" & @CRLF & _
"244990824719" & @CRLF & _
"244991259647" & @CRLF & _
"244925212121" & @CRLF & _
"244954000000" & @CRLF & _
"244964000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")