package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)244[9][19]\d{7}`)
var str = `244929164344
244915392194
244943757798
244922955344
244914094882
244990824719
244991259647
244925212121
244954000000
244964000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}