using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"244[9][19]\d{7}";
string input = @"244929164344
244915392194
244943757798
244922955344
244914094882
244990824719
244991259647
244925212121
244954000000
244964000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}