// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)244[9][19]\d{7}").unwrap();
let string = "244929164344
244915392194
244943757798
244922955344
244914094882
244990824719
244991259647
244925212121
244954000000
244964000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}