$re = '/244[9][19]\d{7}/m';
$str = '244929164344
244915392194
244943757798
244922955344
244914094882
244990824719
244991259647
244925212121
244954000000
244964000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);