#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?\b(max\d+)\b)?.*"
Local $sString = "1. sdfsdf werwe werwemax45 rwrwerwr" & @CRLF & _
"2. 34348878 max max44444445666 sdf" & @CRLF & _
"3. 4353424 23423eedf max55 dfdg dfgdf" & @CRLF & _
"4. max45" & @CRLF & _
"5. 4324234234sdfsdf maxx34534" & @CRLF & _
"max45 here!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")