# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*?\b(max\d+)\b)?.*"
test_str = ("1. sdfsdf werwe werwemax45 rwrwerwr\n"
"2. 34348878 max max44444445666 sdf\n"
"3. 4353424 23423eedf max55 dfdg dfgdf\n"
"4. max45\n"
"5. 4324234234sdfsdf maxx34534\n"
"max45 here!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.