re = /^(?:.*?\b(max\d+)\b)?.*/m
str = '1. sdfsdf werwe werwemax45 rwrwerwr
2. 34348878 max max44444445666 sdf
3. 4353424 23423eedf max55 dfdg dfgdf
4. max45
5. 4324234234sdfsdf maxx34534
max45 here!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end