import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\b(max\\d+)\\b)?.*";
final String string = "1. sdfsdf werwe werwemax45 rwrwerwr\n"
+ "2. 34348878 max max44444445666 sdf\n"
+ "3. 4353424 23423eedf max55 dfdg dfgdf\n"
+ "4. max45\n"
+ "5. 4324234234sdfsdf maxx34534\n"
+ "max45 here!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}