package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?\b(max\d+)\b)?.*`)
var str = `1. sdfsdf werwe werwemax45 rwrwerwr
2. 34348878 max max44444445666 sdf
3. 4353424 23423eedf max55 dfdg dfgdf
4. max45
5. 4324234234sdfsdf maxx34534
max45 here!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}