package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d*\.?\d+\h*A\b`)
var str = `2A,100 A,84.55A,92.1 A`
var substitution = "<i>$0</i>"
fmt.Println(re.ReplaceAllString(str, substitution))
}