import re
regex = re.compile(r"""
\b\d*\.?\d+\h*A\b
""", flags=re.MULTILINE | re.VERBOSE)
test_str = "2A,100 A,84.55A,92.1 A"
subst = "<i>$0</i>"
result = regex.sub(subst, test_str)
if result:
print(result)