re = /\b\d*\.?\d+\h*A\b/mx
str = '2A,100 A,84.55A,92.1 A'
subst = '<i>$0</i>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result