$re = '/\b\d*\.?\d+\h*A\b/mx';
$str = '2A,100 A,84.55A,92.1 A';
$subst = "<i>$0</i>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;