const regex = /\b\d*\.?\d+\h*A\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d*\\.?\\d+\\h*A\\b', 'gm')
const str = `2A,100 A,84.55A,92.1 A`;
const subst = `<i>$0</i>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);