# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\$\w+\['|\G(?!^))\w+\K\h+//gm;t' <<< "$lang['Delivery Charge'] = 'Delivery Charge';
$lang['Frequently Asked Questions'] = 'Frequently Asked Questions';"