const regex = /(?:\$\w+\['|\G(?!^))\w+\K\h+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\$\\w+\\[\'|\\G(?!^))\\w+\\K\\h+', 'gm')
const str = `\$lang['Delivery Charge'] = 'Delivery Charge';
\$lang['Frequently Asked Questions'] = 'Frequently Asked Questions';`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);