use strict;
my $str = '$lang[\'Delivery Charge\'] = \'Delivery Charge\';
$lang[\'Frequently Asked Questions\'] = \'Frequently Asked Questions\';';
my $regex = qr/(?:\$\w+\['|\G(?!^))\w+\K\h+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";