import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "bind:value=\"\\{(.*?)\\}\"";
final String string = "<input type=\"text\" name=\"prop\" bind:value=\"{model.subObject.subSubObject.subSubSubProp}\">\n"
+ "<span class=\"error\" data-error-for=\"prop\"></span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}