const regex = /bind:value="{(.*?)}"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('bind:value="{(.*?)}"', 'gm')
const str = `<input type="text" name="prop" bind:value="{model.subObject.subSubObject.subSubSubProp}">
<span class="error" data-error-for="prop"></span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}