$re = '/bind:value="{(.*?)}"/m';
$str = '<input type="text" name="prop" bind:value="{model.subObject.subSubObject.subSubSubProp}">
<span class="error" data-error-for="prop"></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);