// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)bind:value="{(.*?)}""#).unwrap();
let string = "<input type=\"text\" name=\"prop\" bind:value=\"{model.subObject.subSubObject.subSubSubProp}\">
<span class=\"error\" data-error-for=\"prop\"></span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}