re = /bind:value="{(.*?)}"/m
str = '<input type="text" name="prop" bind:value="{model.subObject.subSubObject.subSubSubProp}">
<span class="error" data-error-for="prop"></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end