#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:print|logg\.debug)\("[^%"]*%[^"]*" % [^()]*(?:(\((?:[^()]++|(?1))*\)))?[^()]*\)"
Local $sString = "print("%s" % error_msg)" & @CRLF & _
"" & @CRLF & _
"logg.debug("in_file: %s, %s" % (in_file, out_file) )" & @CRLF & _
"" & @CRLF & _
"print("partinf_tup: %s, %s" % (access_name, repr(partinf_tup)) )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")