// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\b(?:print|logg\.debug)\("[^%"]*%[^"]*" % [^()]*(?:(\((?:[^()]++|(?1))*\)))?[^()]*\)"#).unwrap();
let string = "print(\"%s\" % error_msg)
logg.debug(\"in_file: %s, %s\" % (in_file, out_file) )
print(\"partinf_tup: %s, %s\" % (access_name, repr(partinf_tup)) )";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}