const regex = /\b(?:print|logg\.debug)\("[^%"]*%[^"]*" % [^()]*(?:(\((?:[^()]++|(?1))*\)))?[^()]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:print|logg\\.debug)\\("[^%"]*%[^"]*" % [^()]*(?:(\\((?:[^()]++|(?1))*\\)))?[^()]*\\)', 'gm')
const str = `print("%s" % error_msg)
logg.debug("in_file: %s, %s" % (in_file, out_file) )
print("partinf_tup: %s, %s" % (access_name, repr(partinf_tup)) )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}