$re = '/\b(?:print|logg\.debug)\("[^%"]*%[^"]*" % [^()]*(?:(\((?:[^()]++|(?1))*\)))?[^()]*\)/m';
$str = 'print("%s" % error_msg)
logg.debug("in_file: %s, %s" % (in_file, out_file) )
print("partinf_tup: %s, %s" % (access_name, repr(partinf_tup)) )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);