import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:print|logg\\.debug)\\(\"[^%\"]*%[^\"]*\" % [^()]*(?:(\\((?:[^()]++|(?1))*\\)))?[^()]*\\)";
final String string = "print(\"%s\" % error_msg)\n\n"
+ "logg.debug(\"in_file: %s, %s\" % (in_file, out_file) )\n\n"
+ "print(\"partinf_tup: %s, %s\" % (access_name, repr(partinf_tup)) )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}